Apache2 + SuSE 9.1 = (unused)

Actualicé el servidor de la facultad, que tenía instalado Linux SuSE 9.0 a la versión 9.1 y al final; el modo gráfico quedó hecho una verdadera cochinada. El sistema no encontraba las rutas de los íconos, de las fuentes y de varias cosas más, la verdad, no tenía sentido trabajar con una versión actualizada pero poco funcional y mucho menos tenía ganas de estar reconfigurando el sistema.

La opción que me pareció viable fue respaldar las carpetas de los usuarios, los archivos más importantes del sistema (bases de datos, contraseñas, archivos .conf y hasta un par de logs) en otro disco duro.

Esta vez, todo el asunto requirió de mucho tiempo porque realizar respaldos (en archivos tar.gz’s) de varios Gb es una tarea leeeeenta, además del contratiempo que tuve a media instalación del sistema porque el 3er disco falló y no logré conseguir otra copia sino hasta el día siguiente.

Al segundo día, los usuarios venían y decían: “Para cuando estará el servidor funcionando”, “Porqué no sirve hardware”, “Tardará mucho?” sumandole a todo lo anterior, que tengo un horario de clases y de trabajo un poco apretado.

Ayer Jueves le dediqué gran parte del día al servidor y a las 9:40 de la noche terminé de poner en funcionamiento los servicios de mysql, ssh, ftp, correo y telnet; todo funcionaba bien, incluso el modo gráfico (con Gnome 2.4 y KDE 3.2.1) … todo funcionaba bien; excepto el servicio de web.
Apache2 no quería por ningún motivo entrar en funcionamiento. No quería y no lo haría…

En la noche ni dormí bien por estar pensando en qué parte de la configuración estaban fallando mis conocimientos linuxeros.

Hoy salí de casa pensando algorítmicamente sobre la posible solución. Estaba decidido a hoy terminaría satisfactoriamente.

Luego de intentar reconfigurar apache por varias horas sin fruto alguno, mejor me puse a googlear un rato y encontré la solución a lo que parece un bug de Apache2 en SuSE9.1.
La solución es algo simple (como suele pasar), y escribo esto porque bien podría ayudarle a más de uno que tenga el mismo problema.

Anuncios

3 pensamientos en “Apache2 + SuSE 9.1 = (unused)

  1. Eit! valar una pregunta, voy a usar suse en un server de producción, pero la pregunta, ya que tu sabes más del asunto, es que si las actualizaciones te las puedes descargar con el YAST ese? que versión tienes tu? me lo vajo de Novell? esta bueno para usar como server de producción?, veras tengo debian, gentoo, fedora, pero jamas he usado suse en un server de producción, me lo recomiendas?

  2. Que tal Robert, pues si… con el YOU (Yast Online Update) puedes realizar las actualizaciones.

    Aqui instale la version 9.1 del Suse y creo que de Novell, solo se puede bajar la version para DVD, los isos andan rolando en la red de manera ilegal, en el ftp de hardware hay un respaldo de los isos. ;-)

    En cuanto a si trabaja bien como server de produccion, io diria que si, como cualquier linux, la onda de Suse es que trae muchisimo software y lo mas nuevo de lo nuevo, a mi parecer, eso lo hace atractivo para el desk.
    Pero la verdad, si se trata de tener un servidor dedicado al 100% al trabajo y no para correr XFree86 lo mejor seria Debian, por su estabilidad.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s